matplotlib(anaconda)更新问题

2022-09-28
前端之家小编收集整理的matplotlib(anaconda)更新问题内容,希望整理的这个开发编程问题matplotlib(anaconda)更新问题能够快速解决!

代码问题

我的matplotlib版本有问题。我不明白为什么,因为上周才下载并安装了新的Ubuntu和anconda。

在图例设置中我的一个笔记本出现错误,我意识到我新安装的matplotlib版本是2.2.2。尽管很奇怪,但我尝试使用

更新它
  

$ conda更新matplotlib

在终端上什么也没做。所以我尝试了命令

  

$ pip install-升级matplotlib

这确实将其更新为3.1.1,但现在我得到一个错误,即未安装其他软件包(例如Pandas)。

我试图通过直接转到导航器并安装我可能会想到的软件包来解决此问题。它起作用了,但是matplotlib恢复了到2.2.2。

要摆脱这个混乱局面,我卸载了anaconda,然后再次将其重新安装。现在matplotlib仍然是2.2.2。

如果有人能告诉我问题的根源和/或解决方法,我将不胜感激。在此先多谢! :)

问题答案

暂无找到可以解决该程序问题的有效方法,小编努力寻找整理中!

如果你已经找到好的解决方法,欢迎将解决方案带上本链接一起发送给小编。

小编邮箱:starryrocklee#gmail.com (将#修改为@)

如果觉得前端之家所整理的内容很不错的话,欢迎点击下方分享按钮,转发给身边开发程序员好友。

编程问答


我正在尝试使用node.js,react和MongoDB将我的应用程序部署到Heroku;部署成功;但是,该网站无法从MongoDB获
里面的箱子有问题吗 <pre><code>case&#39;usal&#39;: d= (while(s2&gt;0)
我正在尝试从Wikipedia中查找页面列表的Wiki ID。这是我的想法,但是在打印“简介”时出现错误:“类型
我正在学习ES6,并且正在学习免费的在线课程。在课程中,我们涵盖了Promises,所以我有: <pre><code>i
当我尝试运行此代码时,它显示“ com.mysql.jdbc.JDBC4ResultSet@7e2d773b”,当前该表只有一条记录。 <pre><co